Ubuntu 16, upgrade 6.8.9-9 to 6.9.3-10

IMagick is a native PHP extension to create and modify images using the ImageMagick API. ImageMagick Studio LLC did not write nor does it maintain the IMagick extension, however, IMagick users are welcome to discuss the extension here.
Post Reply
Posts: 10
Joined: 2017-04-19T03:48:21-07:00
Authentication code: 1151

Ubuntu 16, upgrade 6.8.9-9 to 6.9.3-10

Post by Defacta » 2018-01-16T05:53:42-07:00


I installed imagemagick on my Ubuntu 16.04 server with this easy command:

Code: Select all

apt-get install php-imagick
Everything is installed with good dependencies.

But I would like to install the version 6.9.3. I can't do that with apt and I tried to do it with dpk by downloading files here:
https://www.ubuntuupdates.org/package/c ... k-6-common
And :

Code: Select all

dpkg -i libmagickcore-6.q16-3_6.9.7.4+dfsg-16ubuntu2_amd64.deb libmagickwand-6.q16-3_6.9.7.4+dfsg-16ubuntu2_amd64.deb php-imagick_3.4.3~rc2-2ubuntu2_amd64.deb
But I get some dependencies issues, if I resolve them by upgrading some package I can't do any more "apt-get upgrade" without errors.

Can I download a binary of ImageMagick for PHP which would not depend on packages installed on the server?


Post Reply