Search found 1412 matches

by dlemstra
2018-01-15T15:10:41-07:00
Forum: MagickWand
Topic: MagickSetImageCompression not working
Replies: 13
Views: 2198

Re: MagickSetImageCompression not working

You should use `MagickSetCompression` instead.
by dlemstra
2018-01-14T03:49:41-07:00
Forum: Magick.NET
Topic: find almost completely white pictures
Replies: 2
Views: 1728

Re: find almost completely white pictures

You can use the `FormatExpression` method for this in Magick.NET:

Code: Select all

using (var image = new MagickImage("image1.jpg"))
{
    var mean = image.FormatExpression("%[fx:mean>0.99?1:0]");
    if (mean == "1")
    {
        // Do something...
    }
}
by dlemstra
2018-01-14T03:37:23-07:00
Forum: Magick.NET
Topic: Exception thrown on Linux
Replies: 5
Views: 1239

Re: Exception thrown on Linux

I have thought about making the ImageMagick library static and decided to not do it because I thought that Linux users might prefer to build their own version. But having this as a static library would make it much easier for the users to use. And when someone wants to link other versions of the lib...
by dlemstra
2018-01-14T03:29:33-07:00
Forum: Magick.NET
Topic: difference and mask
Replies: 4
Views: 1205

Re: difference and mask

You will need to use the size of the input image:

Code: Select all

var size = 20;
var geometry = new MagickGeometry(size, size, cloneImg2.Width - size,cloneImg2.Height - size);
cloneImg2.Crop(geometry );
by dlemstra
2018-01-11T15:23:35-07:00
Forum: Developers
Topic: Saving a BMP file with 16 bit pixel resolution (5:6:5)
Replies: 6
Views: 1135

Re: Saving a BMP file with 16 bit pixel resolution (5:6:5)

Maybe you should read your topic again?
by dlemstra
2017-12-31T08:06:47-07:00
Forum: Bugs
Topic: Possible Magic++ bug
Replies: 6
Views: 724

Re: Possible Magic++ bug

I just pushed a patch to remove the restriction. This will be removed in the next release.
by dlemstra
2017-12-29T15:14:45-07:00
Forum: Users
Topic: Set '-quiet' programmicaly
Replies: 3
Views: 695

Re: Set '-quiet' programmicaly

You could use the `quiet(true)` to ignore warnings but you should not get any when you use the constructor to read the image.
by dlemstra
2017-12-26T12:00:22-07:00
Forum: Users
Topic: Create psd file with a single transparent layer
Replies: 41
Views: 2114

Re: Create psd file with a single transparent layer

I don't think the `-define` has ever worked on other images. Maybe that format did not try to make the image grayscale? Only some of the encoders will try to do that.
by dlemstra
2017-12-26T11:51:12-07:00
Forum: Users
Topic: Create psd file with a single transparent layer
Replies: 41
Views: 2114

Re: Create psd file with a single transparent layer

The -define set properties on an internal object called ImageInfo. But the method that makes the image gray only has an Image as input and not an ImageInfo. To set a property on the image itself you will need to use -set instead of -define.
by dlemstra
2017-12-26T11:49:03-07:00
Forum: Bugs
Topic: Problem writing PSB for Photoshop CS6
Replies: 10
Views: 1572

Re: Problem writing PSB for Photoshop CS6

I just pushed a fix for this to our git repository. Can you give it a try with the latest beta tomorrow?
by dlemstra
2017-12-26T11:27:29-07:00
Forum: Users
Topic: Create psd file with a single transparent layer
Replies: 41
Views: 2114

Re: Create psd file with a single transparent layer

You should use `-set colorspace:auto-grayscale false`. The -define will not set it as a property on the image but -set does. Do you get the correct result with the following command?

Code: Select all

convert -size 500x500 xc:none -depth 8 -set colorspace:auto-grayscale off test.psd
by dlemstra
2017-12-24T09:49:41-07:00
Forum: Bugs
Topic: unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7
Replies: 7
Views: 2902

Re: unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7

It seems that Windows no longer (or it never did?) loads referenced libraries from the directory of the executable. The `mod_png` dll is located in the modules/coders directory but it needs the `png` dll that is located in the same folder as the executable. I just pushed a patch with a workaround fo...
by dlemstra
2017-12-24T07:10:22-07:00
Forum: Bugs
Topic: unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7
Replies: 7
Views: 2902

Re: unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7

You are right snibgo. My bad. I just did a quick check and I could run the command without any issues when the file exists but I am getting the same error when I run the command on a file that is missing. I tested this on a Virtual Machine with `ImageMagick-7.0.7-16-Q16-x64-dll` (from appveyor build...
by dlemstra
2017-12-24T06:36:55-07:00
Forum: Bugs
Topic: unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7
Replies: 7
Views: 2902

Re: unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7

It looks like you did not select "Add application directory to your system path" during the installation.